unity安卓编译环境

编译安卓时,如果使用了错误版本的sdk、ndk,都会编译失败。此时,

  1. 可以在设置中选择选择使用unity自带的版本,通过unity hub安装他们。
  2. 也可以在unity hub安装完成后,把sdk 和 ndk复制出来,放到自定义路径保存起来。
  3. 也可以自己安装unity指定的版本,然后指定路径。这样就不用安装多余的sdk。
  4. 也可以安装同一大版本下的较高版本,比如unity需要19.0,我们可以安装19.2,默认情况下,unity此时会弹框或者拒绝接受更高版本。那我们可以到ndk目录下找到sources.properties文件,直接修改其中的版本号为unity需要的版本。

官方文档中给出了所需要的版本信息:

https://docs.unity3d.com/2020.1/Documentation/Manual/system-requirements.html#mobile

调到mobile部分即可看到。

发表评论

电子邮件地址不会被公开。 必填项已用*标注

2 + 5 =